pingvin2.jpg

Grub2 RAID1 boot probléma

Írta: Torig on . Beküldve: Linuxos apróságok

Mi van akkor, ha lemezt cserélsz a RAID tömbben, mindent jól csinálsz, mégsem indul el a rendszer az új lemezről, hanem indulás helyett folyamatosan újraindul a gép.

A közelmúltban ki kellett cseréljem az egyik szerveremben lévő lemezt. A feladat egyszerűnek tűnt. Lemez eltávolítása a RAID tömbből. Gép leállítás, majd beszerelem az új lemezt. Indítás, particionálás, hozzáadás a RAID tömbhöz. A z adatok szinkronizálása hiba nélkül befejeződik. Aztán Grub install és Grub update. Az egész max 20 perc. Lenne. Aztán több nap szívás és keresgélés lett belőle.

Konfiguráció: Ubuntu Szerver 12.04 LTS, 2 db lemez RAID 1 tömbben. Grub2.

A hibajelenség a következő. Az egész procedúra végén tesztelni szerettem volna, hogy a rendszer képes elindulni bármelyik lemezről. Az egyik lemezről ami a gépben volt, simán bootolt. Ez a lemez volt benne a gép telepítése óta. Nem volt vele soha semmi gond. Az új lemezről viszont nem indult el a gép. A gép bootol, aztán megjelenik a Grub menü, aztán a gép resetel és újraindul. Aztán csinálja a végtelenségig, amíg el nem unom.

Nos hamar eluntam és napokig azon agyaltam mi lehet a probléma. Hibás lemez? Nem. Hibás alaplap? Nem. Arra gondoltam, hogy a partíció, vagy az MBR lehet hibás, de az is jó. Amikor már mindent kizártam amit tudtam elkezdtem a Grub konfigurációján agyalni. A megoldás a következő.

A /etc/default/grub fájlban az alábbi sor elől ki kellett venni a kommentet.

...
GRUB_TERMINAL=console
...

Aztán frissíteni kell a Grub konfigurációját.

update-grub

Újraindítás után csodák-csodája bármelyik lemezről el tud indulni a rendszer. Ahogy az mindig is dolga lett volna. Elgondolkodtam rajta, hogy ha ez a telepítés utáni alap beállítás, akkor hányan szívták be a dolgot. Adatvesztés nincs, mert a RAID teszi a dolgát. Csak hát nem indul el a gép ha az egyik lemez kiesik a rendszerből.

Tanulság. Lemez csere után mindig teszteld le a rendszer indíthatóságát!